summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-03-12 10:11:24 +0100
committerChristian Grothoff <christian@grothoff.org>2020-03-12 10:11:24 +0100
commit83631bc98fe70dd73f212581fb54ab3a82560686 (patch)
tree058fd4b741f2dc650da5aee21af61df3ddf3d98b /src/exchange/Makefile.am
parenta1db41e09a618c3a9797242ee593da1331175c14 (diff)
downloadexchange-83631bc98fe70dd73f212581fb54ab3a82560686.tar.gz
exchange-83631bc98fe70dd73f212581fb54ab3a82560686.tar.bz2
exchange-83631bc98fe70dd73f212581fb54ab3a82560686.zip
split reserve closing from main aggregation logic
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index 61d3341cc..227224d30 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -18,6 +18,7 @@ pkgcfg_DATA = \
bin_PROGRAMS = \
taler-exchange-aggregator \
+ taler-exchange-closer \
taler-exchange-httpd \
taler-exchange-wirewatch
@@ -33,6 +34,19 @@ taler_exchange_aggregator_LDADD = \
-lgnunetcurl \
-lgnunetutil
+
+taler_exchange_closer_SOURCES = \
+ taler-exchange-closer.c
+taler_exchange_closer_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ -ljansson \
+ -lgnunetcurl \
+ -lgnunetutil
+
taler_exchange_wirewatch_SOURCES = \
taler-exchange-wirewatch.c
taler_exchange_wirewatch_LDADD = \