summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
authorÖzgür Kesim <oec-taler@kesim.org>2021-12-23 15:15:33 +0100
committerÖzgür Kesim <oec-taler@kesim.org>2021-12-23 15:15:33 +0100
commit1b23857f2cb56f4aa95a07d7c52bd48abc20b73b (patch)
treec13076f2420d8a3d28d256368a6c9477b8391cf7 /src/exchange/Makefile.am
parent62444504f78976137569d635b34fdbedeb6ccc5c (diff)
downloadexchange-1b23857f2cb56f4aa95a07d7c52bd48abc20b73b.tar.gz
exchange-1b23857f2cb56f4aa95a07d7c52bd48abc20b73b.tar.bz2
exchange-1b23857f2cb56f4aa95a07d7c52bd48abc20b73b.zip
[age restriction] progress 8/n
More work towards support for extensions and age restriction - updated gana - added handler for DB-Event - added TEH_extensions_init() and _done() - added global for age restriction - added stub for post handler - added SQL-table for extension metadata - added enum type for extensions and other data structures Also: - fixed some warnings -Wmaybe-unitialized
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index 3009c84c2..c20378c22 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -82,6 +82,7 @@ taler_exchange_httpd_SOURCES = \
taler-exchange-httpd_db.c taler-exchange-httpd_db.h \
taler-exchange-httpd_deposit.c taler-exchange-httpd_deposit.h \
taler-exchange-httpd_deposits_get.c taler-exchange-httpd_deposits_get.h \
+ taler-exchange-httpd_extensions.c taler-exchange-httpd_extensions.h \
taler-exchange-httpd_keys.c taler-exchange-httpd_keys.h \
taler-exchange-httpd_kyc-check.c taler-exchange-httpd_kyc-check.h \
taler-exchange-httpd_kyc-proof.c taler-exchange-httpd_kyc-proof.h \
@@ -91,6 +92,7 @@ taler_exchange_httpd_SOURCES = \
taler-exchange-httpd_management_auditors.c \
taler-exchange-httpd_management_auditors_AP_disable.c \
taler-exchange-httpd_management_denominations_HDP_revoke.c \
+ taler-exchange-httpd_management_extensions.c \
taler-exchange-httpd_management_post_keys.c \
taler-exchange-httpd_management_signkey_EP_revoke.c \
taler-exchange-httpd_management_wire_enable.c \
@@ -109,9 +111,6 @@ taler_exchange_httpd_SOURCES = \
taler-exchange-httpd_wire.c taler-exchange-httpd_wire.h \
taler-exchange-httpd_withdraw.c taler-exchange-httpd_withdraw.h
-# taler-exchange-httpd_management_post_keys.c
-
-
taler_exchange_httpd_LDADD = \
$(LIBGCRYPT_LIBS) \
$(top_builddir)/src/bank-lib/libtalerbank.la \