summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-04-17 23:14:23 +0200
committerChristian Grothoff <christian@grothoff.org>2016-04-17 23:14:23 +0200
commit8d503b17e3bd2f1ee4d54c13bb7c4221e4b6068b (patch)
tree0c73d67b6456ea3dfebd258ce3a690c563389394 /src/exchange/Makefile.am
parent4dcd70ac2bcf2642e1725f55cc26739bd91e4d1e (diff)
downloadexchange-8d503b17e3bd2f1ee4d54c13bb7c4221e4b6068b.tar.gz
exchange-8d503b17e3bd2f1ee4d54c13bb7c4221e4b6068b.tar.bz2
exchange-8d503b17e3bd2f1ee4d54c13bb7c4221e4b6068b.zip
move fake bank implementation to new library to re-use the code in upcoming testcases in preparation of fixing #4399
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index a283e78b8..8dcd2e689 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -1,5 +1,5 @@
# This Makefile.am is in the public domain
-AM_CPPFLAGS = -I$(top_srcdir)/src/include
+AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/bank-lib/
if USE_COVERAGE
AM_CFLAGS = --coverage -O0
@@ -70,6 +70,7 @@ test_taler_exchange_aggregator_postgres_SOURCES = \
test_taler_exchange_aggregator_postgres_LDADD = \
$(LIBGCRYPT_LIBS) \
$(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ $(top_builddir)/src/bank-lib/libfakebank.la \
$(top_builddir)/src/json/libtalerjson.la \
$(top_builddir)/src/util/libtalerutil.la \
-lmicrohttpd \