summaryrefslogtreecommitdiff
path: root/src/exchange-tools/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-11-12 22:25:59 +0100
committerChristian Grothoff <christian@grothoff.org>2020-11-12 22:25:59 +0100
commit45d621f5ff16c8c6a559f9e865704e8090885799 (patch)
treeda1fa1269f2202b6dbd68865a72b12941f7acbe2 /src/exchange-tools/Makefile.am
parent2ad4cee183dde4d40171dc9222fa754bbf341cae (diff)
downloadexchange-45d621f5ff16c8c6a559f9e865704e8090885799.tar.gz
exchange-45d621f5ff16c8c6a559f9e865704e8090885799.tar.bz2
exchange-45d621f5ff16c8c6a559f9e865704e8090885799.zip
add -lgcov flag for coverage analysis
Diffstat (limited to 'src/exchange-tools/Makefile.am')
-rw-r--r--src/exchange-tools/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/exchange-tools/Makefile.am b/src/exchange-tools/Makefile.am
index 943982567..a3689d81d 100644
--- a/src/exchange-tools/Makefile.am
+++ b/src/exchange-tools/Makefile.am
@@ -26,7 +26,8 @@ taler_exchange_keyup_LDADD = \
$(top_builddir)/src/json/libtalerjson.la \
$(top_builddir)/src/pq/libtalerpq.la \
$(top_builddir)/src/util/libtalerutil.la \
- -lgnunetutil $(XLIB)
+ -lgnunetutil \
+ $(XLIB)
taler_exchange_keyup_LDFLAGS = $(POSTGRESQL_LDFLAGS)
@@ -40,7 +41,8 @@ taler_exchange_wire_LDADD = \
$(top_builddir)/src/util/libtalerutil.la \
-lgnunetjson \
-lgnunetutil \
- -ljansson $(XLIB)
+ -ljansson \
+ $(XLIB)
taler_exchange_wire_LDFLAGS = $(POSTGRESQL_LDFLAGS)
taler_exchange_keycheck_SOURCES = \
@@ -49,7 +51,8 @@ taler_exchange_keycheck_LDADD = \
$(LIBGCRYPT_LIBS) \
$(top_builddir)/src/util/libtalerutil.la \
$(top_builddir)/src/exchangedb/libtalerexchangedb.la \
- -lgnunetutil $(XLIB)
+ -lgnunetutil \
+ $(XLIB)
taler_exchange_keycheck_LDFLAGS = $(POSTGRESQL_LDFLAGS)
taler_exchange_dbinit_SOURCES = \
@@ -59,7 +62,8 @@ taler_exchange_dbinit_LDADD = \
$(top_builddir)/src/util/libtalerutil.la \
$(top_builddir)/src/pq/libtalerpq.la \
$(top_builddir)/src/exchangedb/libtalerexchangedb.la \
- -lgnunetutil $(XLIB)
+ -lgnunetutil \
+ $(XLIB)
taler_exchange_dbinit_LDFLAGS = \
$(POSTGRESQL_LDFLAGS)
taler_exchange_dbinit_CPPFLAGS = \