summaryrefslogtreecommitdiff
path: root/src/benchmark/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-06-19 13:59:03 +0200
committerChristian Grothoff <christian@grothoff.org>2021-06-19 13:59:03 +0200
commitfdf095c6efae2e6c59712996ca380bc499229370 (patch)
tree72a4d1494f1bb6be88e6765dbe011c9deb3f0213 /src/benchmark/Makefile.am
parent50749c462b55b05d42ca518572f75101401089d5 (diff)
downloadexchange-fdf095c6efae2e6c59712996ca380bc499229370.tar.gz
exchange-fdf095c6efae2e6c59712996ca380bc499229370.tar.bz2
exchange-fdf095c6efae2e6c59712996ca380bc499229370.zip
initial version of taler-bank-benchmark
Diffstat (limited to 'src/benchmark/Makefile.am')
-rw-r--r--src/benchmark/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/benchmark/Makefile.am b/src/benchmark/Makefile.am
index af1f5b94c..89dc30061 100644
--- a/src/benchmark/Makefile.am
+++ b/src/benchmark/Makefile.am
@@ -11,8 +11,24 @@ if USE_COVERAGE
endif
bin_PROGRAMS = \
+ taler-bank-benchmark \
taler-exchange-benchmark
+taler_bank_benchmark_SOURCES = \
+ taler-bank-benchmark.c
+taler_bank_benchmark_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/testing/libtalertesting.la \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
taler_exchange_benchmark_SOURCES = \
taler-exchange-benchmark.c
taler_exchange_benchmark_LDADD = \