summaryrefslogtreecommitdiff
path: root/src/benchmark/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2016-05-30 15:08:12 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2016-05-30 15:08:12 +0200
commit848c7f0e4fe3adde77e1cb1e1b4677dd5ef2ca0e (patch)
treecae411b2c233a535027120f874f5ec4f88948944 /src/benchmark/Makefile.am
parent1982fdd81cb7284c883dd810aef2827c19a54209 (diff)
downloadexchange-848c7f0e4fe3adde77e1cb1e1b4677dd5ef2ca0e.tar.gz
exchange-848c7f0e4fe3adde77e1cb1e1b4677dd5ef2ca0e.tar.bz2
exchange-848c7f0e4fe3adde77e1cb1e1b4677dd5ef2ca0e.zip
benchmark makefile
Diffstat (limited to 'src/benchmark/Makefile.am')
-rw-r--r--src/benchmark/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/benchmark/Makefile.am b/src/benchmark/Makefile.am
new file mode 100644
index 000000000..4deb81723
--- /dev/null
+++ b/src/benchmark/Makefile.am
@@ -0,0 +1,22 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+bin_PROGRAMS = \
+ taler-exchange-benchmark
+
+taler_exchange_benchmark_SOURCES = \
+ taler-exchange-benchmark.c
+taler_exchange_benchmark_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson