summaryrefslogtreecommitdiff
path: root/src/auditor/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-01-11 19:04:49 +0100
committerChristian Grothoff <christian@grothoff.org>2021-01-11 19:04:49 +0100
commite3156e88a783e5fdfc5e31bcc6f357d33af7f634 (patch)
tree9545859aadc7f0e90daa5aa310bc776296b8fed1 /src/auditor/Makefile.am
parent5eed6115940b7d386cb9a653dac039aa22b4ba02 (diff)
downloadexchange-e3156e88a783e5fdfc5e31bcc6f357d33af7f634.tar.gz
exchange-e3156e88a783e5fdfc5e31bcc6f357d33af7f634.tar.bz2
exchange-e3156e88a783e5fdfc5e31bcc6f357d33af7f634.zip
sync skeleton
Diffstat (limited to 'src/auditor/Makefile.am')
-rw-r--r--src/auditor/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/auditor/Makefile.am b/src/auditor/Makefile.am
index 0ff90020c..6432b61d1 100644
--- a/src/auditor/Makefile.am
+++ b/src/auditor/Makefile.am
@@ -18,6 +18,7 @@ bin_PROGRAMS = \
taler-auditor-dbinit \
taler-auditor-exchange \
taler-auditor-httpd \
+ taler-auditor-sync \
taler-helper-auditor-aggregation \
taler-helper-auditor-coins \
taler-helper-auditor-deposits \
@@ -170,6 +171,23 @@ taler_auditor_exchange_LDADD = \
-lgnunetutil \
$(XLIB)
+taler_auditor_sync_SOURCES = \
+ taler-auditor-sync.c
+taler_auditor_sync_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ -lgnunetutil \
+ $(XLIB)
+taler_auditor_dbinit_LDFLAGS = \
+ $(POSTGRESQL_LDFLAGS)
+taler_auditor_dbinit_CPPFLAGS = \
+ -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/pq/ \
+ $(POSTGRESQL_CPPFLAGS)
+
+
check_SCRIPTS = \
test-auditor.sh \
test-revocation.sh