summaryrefslogtreecommitdiff
path: root/src/auditor/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-10-06 15:17:10 +0200
committerChristian Grothoff <christian@grothoff.org>2016-10-06 15:17:10 +0200
commitb68adb93c6e0bcb225e115cd62e23f1318ef259b (patch)
tree2628579646ee622873cc21b37acee02d0084f870 /src/auditor/Makefile.am
parentf1a71f180c7bac551c8d4de2531172be561d5103 (diff)
downloadexchange-b68adb93c6e0bcb225e115cd62e23f1318ef259b.tar.gz
exchange-b68adb93c6e0bcb225e115cd62e23f1318ef259b.tar.bz2
exchange-b68adb93c6e0bcb225e115cd62e23f1318ef259b.zip
adding skeleton code for auditor
Diffstat (limited to 'src/auditor/Makefile.am')
-rw-r--r--src/auditor/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/auditor/Makefile.am b/src/auditor/Makefile.am
new file mode 100644
index 000000000..c0868ce76
--- /dev/null
+++ b/src/auditor/Makefile.am
@@ -0,0 +1,28 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+pkgcfgdir = $(prefix)/share/taler/config.d/
+
+pkgcfg_DATA = \
+ auditor.conf
+
+bin_PROGRAMS = \
+ taler-auditor
+
+taler_auditor_SOURCES = \
+ taler-auditor.c
+taler_auditor_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/wire/libtalerwire.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ $(top_builddir)/src/auditordb/libtalerauditordb.la \
+ -lgnunetutil
+
+EXTRA_DIST = \
+ auditor.conf