summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2020-01-16 14:11:54 +0100
committerFlorian Dold <florian.dold@gmail.com>2020-01-16 14:12:47 +0100
commit7fad7cb71603878943ee6193056142097cd8ccd3 (patch)
tree550609396cfee4f5e241ef27c32ffea881ba09d6 /src/Makefile.am
parentf8385eeabd64cc3eb7d4df21a5994f6990b00f07 (diff)
downloadexchange-7fad7cb71603878943ee6193056142097cd8ccd3.tar.gz
exchange-7fad7cb71603878943ee6193056142097cd8ccd3.tar.bz2
exchange-7fad7cb71603878943ee6193056142097cd8ccd3.zip
make lib(c|gn)url mandatory, cleaner makefiles
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d3fde4c1d..8ad3e88e9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,13 +3,6 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
if HAVE_POSTGRESQL
PQ_DIR = pq
endif
-if HAVE_LIBCURL
- BANK_LIB = bank-lib
-else
-if HAVE_LIBGNURL
- BANK_LIB = bank-lib
-endif
-endif
pkgcfgdir = $(prefix)/share/taler/config.d/
pkgcfg_DATA = \
@@ -18,11 +11,18 @@ pkgcfg_DATA = \
EXTRA_DIST = \
taler.conf
-SUBDIRS = include util json curl $(PQ_DIR) mhd $(BANK_LIB) exchangedb exchange exchange-tools auditordb auditor
-if HAVE_LIBCURL
- SUBDIRS += lib benchmark
-else
-if HAVE_LIBGNURL
- SUBDIRS += lib benchmark
-endif
-endif
+SUBDIRS = \
+ include \
+ util \
+ json \
+ curl \
+ $(PQ_DIR) \
+ mhd \
+ bank-lib \
+ exchangedb \
+ exchange \
+ exchange-tools \
+ auditordb \
+ auditor \
+ lib \
+ benchmark