summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-28 11:34:06 +0200
committerChristian Grothoff <christian@grothoff.org>2015-05-28 11:34:06 +0200
commitde953fa7bcdcfa78606753285911a6a49120327f (patch)
tree203bb8ac7722d260461c656e3f409cf1363f6051 /src/Makefile.am
parentc742db86c44c7da89d62b6b4ed031dd4bdf74e38 (diff)
downloadexchange-de953fa7bcdcfa78606753285911a6a49120327f.tar.gz
exchange-de953fa7bcdcfa78606753285911a6a49120327f.tar.bz2
exchange-de953fa7bcdcfa78606753285911a6a49120327f.zip
add --enable-wallet-only flag to build libtalerutil_wallet which ONLY contains the wallet-specific API subset
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e3a17f723..888cbabf1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,13 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
if HAVE_POSTGRESQL
PQ_DIR = pq
endif
-SUBDIRS = include util $(PQ_DIR) mintdb mint mint-tools
+if WALLET_ONLY
+SUBDIRS = include util
+else
+
+SUBDIRS = include util $(PQ_DIR) mintdb mint mint-tools
if HAVE_LIBCURL
SUBDIRS += mint-lib
endif
+
+endif