summaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-07-04 00:25:02 +0200
committerChristian Grothoff <christian@grothoff.org>2018-07-04 00:25:02 +0200
commitbc5d9b492f609ac08573052288d0503b6d044cb5 (patch)
treee9a5360f5166fdbe5fa3e15c1bb7064cf43524d9 /m4
parent2128cf6f4188d39c09aba5afa31b4f21ef156aee (diff)
downloadexchange-bc5d9b492f609ac08573052288d0503b6d044cb5.tar.gz
exchange-bc5d9b492f609ac08573052288d0503b6d044cb5.tar.bz2
exchange-bc5d9b492f609ac08573052288d0503b6d044cb5.zip
fix pg version check on Debian
Diffstat (limited to 'm4')
-rw-r--r--m4/ax_lib_postgresql.m47
1 files changed, 3 insertions, 4 deletions
diff --git a/m4/ax_lib_postgresql.m4 b/m4/ax_lib_postgresql.m4
index e81c0996..11b6991f 100644
--- a/m4/ax_lib_postgresql.m4
+++ b/m4/ax_lib_postgresql.m4
@@ -38,7 +38,6 @@
# LICENSE
#
# Copyright (c) 2008 Mateusz Loskot <mateusz@loskot.net>
-# Copyright (c) 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
#
# Copying and distribution of this file, with or without modification, are
# permitted in any medium without royalty provided the copyright notice
@@ -81,7 +80,7 @@ AC_DEFUN([AX_LIB_POSTGRESQL],
fi
if test ! -x "$PG_CONFIG"; then
- AC_MSG_ERROR([$PG_CONFIG does not exist or it is not an exectuable file])
+ dnl AC_MSG_ERROR([$PG_CONFIG does not exist or it is not an exectuable file])
PG_CONFIG="no"
found_postgresql="no"
fi
@@ -92,7 +91,7 @@ AC_DEFUN([AX_LIB_POSTGRESQL],
POSTGRESQL_CPPFLAGS="-I`$PG_CONFIG --includedir`"
POSTGRESQL_LDFLAGS="-L`$PG_CONFIG --libdir`"
- POSTGRESQL_VERSION=`$PG_CONFIG --version | sed -e 's#PostgreSQL ##'`
+ POSTGRESQL_VERSION=`$PG_CONFIG --version | sed -e 's#PostgreSQL ##' | awk '{print $1}'`
AC_DEFINE([HAVE_POSTGRESQL], [1],
[Define to 1 if PostgreSQL libraries are available])
@@ -114,7 +113,7 @@ AC_DEFUN([AX_LIB_POSTGRESQL],
if test "$found_postgresql" = "yes" -a -n "$postgresql_version_req"; then
- AC_MSG_CHECKING([if PostgreSQL version is >= $postgresql_version_req])
+ AC_MSG_CHECKING([if PostgreSQL version $POSTGRESQL_VERSION is >= $postgresql_version_req])
dnl Decompose required version string of PostgreSQL
dnl and calculate its number representation