summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-02-07 00:54:01 +0100
committerChristian Grothoff <christian@grothoff.org>2020-02-07 00:54:47 +0100
commitf1cbc109f7cb6908469f1b8de5a10accff95244e (patch)
tree15a693cd7ba07e5993146ba2bc5815cb3aa9da43 /contrib/Makefile.am
parenteae85d62c10907a71b9087866669a46907411023 (diff)
downloadexchange-f1cbc109f7cb6908469f1b8de5a10accff95244e.tar.gz
exchange-f1cbc109f7cb6908469f1b8de5a10accff95244e.tar.bz2
exchange-f1cbc109f7cb6908469f1b8de5a10accff95244e.zip
add proper i18n for pp
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 5a165d1fb..eb4ad312d 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = . pp
+SUBDIRS = .
# English (en)
tosendir=$(pkgdatadir)/tos/en
@@ -13,6 +13,13 @@ tosen_DATA = \
tos/en/0.xml \
tos/en/0.html
+ppen_DATA = \
+ pp/en/0.txt \
+ pp/en/0.pdf \
+ pp/en/0.epub \
+ pp/en/0.xml \
+ pp/en/0.html
+
bin_SCRIPTS = \
taler-bank-manage-testing \
taler-exchange-revoke
@@ -21,11 +28,17 @@ EXTRA_DIST = \
$(bin_SCRIPTS) \
$(tosen_DATA) \
update-tos.sh \
+ update-pp.sh \
tos/Makefile \
tos/README \
tos/tos.rst \
tos/conf.py \
tos/locale/de/LC_MESSAGES/tos.po \
+ pp/Makefile \
+ pp/README \
+ pp/tos.rst \
+ pp/conf.py \
+ pp/locale/pp/LC_MESSAGES/pp.po \
auditor-report.tex.j2 \
coverage.sh \
gnunet.tag \
@@ -35,11 +48,15 @@ EXTRA_DIST = \
# Change the set of supported languages here. You should
# also update tos'XX'data and EXTRA_DIST accordingly.
TOS_LANGUAGES="en de"
+PP_LANGUAGES="en de"
# Change the terms-of-service version (Etag) to generate here!
# This value should be incremented whenever there is a substantive
# change in the original text (but not for the translations).
TOS_VERSION=0
+PP_VERSION=0
update-tos:
VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
+update-pp:
+ VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)