summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-02-07 00:44:35 +0100
committerChristian Grothoff <christian@grothoff.org>2020-02-07 00:44:35 +0100
commiteae85d62c10907a71b9087866669a46907411023 (patch)
tree1e39a28531022ddb04524d74f3c954269d2599a3 /contrib/Makefile.am
parent9e0a813b38b791a0bc020b8f1ee16d2b5d8712c6 (diff)
downloadexchange-eae85d62c10907a71b9087866669a46907411023.tar.gz
exchange-eae85d62c10907a71b9087866669a46907411023.tar.bz2
exchange-eae85d62c10907a71b9087866669a46907411023.zip
proper i18n support for TOS
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am34
1 files changed, 33 insertions, 1 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index c38a1630f..5a165d1fb 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,4 +1,17 @@
-SUBDIRS = . tos pp
+SUBDIRS = . pp
+
+# English (en)
+tosendir=$(pkgdatadir)/tos/en
+
+# English (en)
+ppendir=$(pkgdatadir)/pp/en
+
+tosen_DATA = \
+ tos/en/0.txt \
+ tos/en/0.pdf \
+ tos/en/0.epub \
+ tos/en/0.xml \
+ tos/en/0.html
bin_SCRIPTS = \
taler-bank-manage-testing \
@@ -6,8 +19,27 @@ bin_SCRIPTS = \
EXTRA_DIST = \
$(bin_SCRIPTS) \
+ $(tosen_DATA) \
+ update-tos.sh \
+ tos/Makefile \
+ tos/README \
+ tos/tos.rst \
+ tos/conf.py \
+ tos/locale/de/LC_MESSAGES/tos.po \
auditor-report.tex.j2 \
coverage.sh \
gnunet.tag \
microhttpd.tag \
render.py
+
+# Change the set of supported languages here. You should
+# also update tos'XX'data and EXTRA_DIST accordingly.
+TOS_LANGUAGES="en de"
+
+# Change the terms-of-service version (Etag) to generate here!
+# This value should be incremented whenever there is a substantive
+# change in the original text (but not for the translations).
+TOS_VERSION=0
+
+update-tos:
+ VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)