summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThien-Thi Nguyen <ttn@gnuvola.org>2022-03-19 07:52:15 -0400
committerThien-Thi Nguyen <ttn@gnuvola.org>2022-03-19 07:52:53 -0400
commitb4f7231d17ce995bd4b36776a01e3e2ececbe3bd (patch)
tree8abf298e87a0479116311ac0af6dc41193593bb3 /configure.ac
parent98c21a5116aa550e4ef3e433be61af54dec2d173 (diff)
downloadexchange-b4f7231d17ce995bd4b36776a01e3e2ececbe3bd.tar.gz
exchange-b4f7231d17ce995bd4b36776a01e3e2ececbe3bd.tar.bz2
exchange-b4f7231d17ce995bd4b36776a01e3e2ececbe3bd.zip
[build int] Use ‘MHD_VERSION_AT_LEAST’
* configure.ac (microhttpd): Delete shell var. (MHD_start_daemon): Delete AC_CHECK_LIB. (MHD_DAEMON_INFO_CURRENT_CONNECTIONS): Delete AC_CHECK_DECL. (MHD_VERSION_AT_LEAST): New macro call.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 5efd4d669..01f1dc20d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -291,7 +291,6 @@ AC_CHECK_HEADERS([gnunet/gnunet_sq_lib.h],
# check for libmicrohttpd
-microhttpd=0
AC_MSG_CHECKING([for microhttpd])
AC_ARG_WITH([microhttpd],
[AS_HELP_STRING([--with-microhttpd=PFX], [base of microhttpd installation])],
@@ -303,14 +302,7 @@ AS_CASE([$with_microhttpd],
[no], [AC_MSG_ERROR([--with-microhttpd is required])],
[LDFLAGS="-L$with_microhttpd/lib $LDFLAGS"
CPPFLAGS="-I$with_microhttpd/include $CPPFLAGS"])
-AC_CHECK_LIB(microhttpd,MHD_start_daemon,
- [AC_CHECK_HEADER([microhttpd.h],[microhttpd=1])])
-AC_CHECK_DECL([MHD_DAEMON_INFO_CURRENT_CONNECTIONS],,[microhttpd=0],[[#include <microhttpd.h>]])
-AS_IF([test $microhttpd = 0],
- [AC_MSG_ERROR([[
-***
-*** You need libmicrohttpd >= 0.9.39 to build this program.
-*** ]])])
+MHD_VERSION_AT_LEAST([0.9.39])
# check for libjansson (Jansson JSON library)
jansson=0