summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-01-05 11:16:27 +0100
committerFlorian Dold <florian@dold.me>2021-01-05 11:16:38 +0100
commit792d1f5f207dac31cb0b648e66970442933039c9 (patch)
treee73b13f0af03096efed87e766b32a616adb75415 /configure.ac
parentaaeadf1598baf7b2193d03b17c73dcd8956dc9cb (diff)
downloadexchange-792d1f5f207dac31cb0b648e66970442933039c9.tar.gz
exchange-792d1f5f207dac31cb0b648e66970442933039c9.tar.bz2
exchange-792d1f5f207dac31cb0b648e66970442933039c9.zip
Revert "always and only build docs"
This reverts commit cdda3d34a3a3b8133a90d934707bf9065fd4471f.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b47aeb982..cc8accf4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,18 @@ DX_INIT_DOXYGEN([taler-exchange],,,
DX_CHI_FEATURE(OFF),
DX_XML_FEATURE(OFF))
+AC_MSG_CHECKING([whether to compile documentation ONLY])
+AC_ARG_ENABLE([only-doc],
+ [AS_HELP_STRING([--enable-only-doc], [only compile Taler documentation])],
+ [doc_only=${enableval}],
+ [doc_only=no])
+AC_MSG_RESULT($doc_only)
+AM_CONDITIONAL([DOC_ONLY], [test "x$doc_only" = "xyes"])
+
+
+# Not indented, as most of the file falls under this one...
+AS_IF([test "x$doc_only" != xyes],[
+
# Checks for programs.
AC_PROG_CC
@@ -489,6 +501,32 @@ AC_TYPE_UINTMAX_T
# Checks for library functions.
AC_CHECK_FUNCS([strdup])
+
+AC_ARG_ENABLE([[doc]],
+ [AS_HELP_STRING([[--disable-doc]], [do not build any documentation])], ,
+ [enable_doc=yes])
+test "x$enable_doc" = "xno" || enable_doc=yes
+AM_CONDITIONAL([ENABLE_DOC], [test "x$enable_doc" = "xyes"])
+
+
+],[ # This is the big test "$doc_only" on top of the file!
+
+
+# logic if doc_only is set, make sure conditionals are still defined
+AM_CONDITIONAL([HAVE_EXPENSIVE_TESTS], [false])
+AM_CONDITIONAL([MHD_HAVE_EPOLL], [false])
+AM_CONDITIONAL([HAVE_POSTGRESQL], [false])
+AM_CONDITIONAL([HAVE_SQLITE], [false])
+AM_CONDITIONAL([HAVE_LIBCURL], [false])
+AM_CONDITIONAL([HAVE_LIBGNURL], [false])
+AM_CONDITIONAL([HAVE_DEVELOPER], [false])
+AM_CONDITIONAL([USE_COVERAGE], [false])
+AM_CONDITIONAL([ENABLE_DOC], [true])
+AM_CONDITIONAL([HAVE_TWISTER], [false])
+
+# end of 'doc_only'
+])
+
AC_CONFIG_FILES([Makefile
contrib/Makefile
doc/Makefile