summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-11-11 15:46:04 +0100
committerChristian Grothoff <christian@grothoff.org>2016-11-11 15:46:09 +0100
commitcd4616dc34d186db07ff0cdd115e694dda02405f (patch)
tree47df58d91b03ae894afb466ab9880c09dbff75fc /configure.ac
parent44ddaaca7fb1f16c804d31d5414960a07900d087 (diff)
downloadexchange-cd4616dc34d186db07ff0cdd115e694dda02405f.tar.gz
exchange-cd4616dc34d186db07ff0cdd115e694dda02405f.tar.bz2
exchange-cd4616dc34d186db07ff0cdd115e694dda02405f.zip
-only enable developer logic if MHD is recent enough
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index df75292a..e93fd7ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,6 +362,8 @@ AC_MSG_RESULT($enable_developer)
AM_CONDITIONAL([HAVE_DEVELOPER], [test "x$enable_developer" = "xyes"])
enable_dev=1
AS_IF([test "x$enableval" = "xno"], [enable_dev=0])
+# developer-logic requires a more recent MHD than usual.
+AC_CHECK_DECL([MHD_OPTION_NOTIFY_CONNECTION],,[enable_dev=0],[[#include <microhttpd.h>]])
AC_DEFINE_UNQUOTED([HAVE_DEVELOPER],[$enable_dev],[1 if developer logic is enabled, 0 otherwise])