summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2019-05-01 02:41:40 +0200
committerFlorian Dold <florian.dold@gmail.com>2019-05-01 02:41:50 +0200
commitcce67665f702fe10df64c1bad6a1bf6cf19c06ab (patch)
tree388ecc710c40601f97196eb1cd31e3456da955dc /configure.ac
parent6e33de941e9a8fd63049337293be212f97555f1a (diff)
downloadexchange-cce67665f702fe10df64c1bad6a1bf6cf19c06ab.tar.gz
exchange-cce67665f702fe10df64c1bad6a1bf6cf19c06ab.tar.bz2
exchange-cce67665f702fe10df64c1bad6a1bf6cf19c06ab.zip
save and restore CFLAGS/LDFLAGS/LIBS when checking for gnurl/curl
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 842f24a5..3c1d9dd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,10 @@ AS_IF([test $libgnunetjson != 1],
*** ]])])
+# Save before checking libgnurl/libcurl
+CFLAGS_SAVE=$CFLAGS
+LDFLAGS_SAVE=$LDFLAGS
+LIBS_SAVE=$LIBS
# check for libgnurl
# libgnurl
@@ -240,6 +244,10 @@ AS_IF([test $libgnunetcurl != 1],
*** ]])])
+# Restore after gnurl/curl checks messed up these values
+CFLAGS=$CFLAGS_SAVE
+LDFLAGS=$LDFLAGS_SAVE
+LIBS=$LIBS_SAVE
# Check for GNUnet's libgnunetpq.
libgnunetpq=0
@@ -325,9 +333,9 @@ else
CFLAGS_SAVE=$CFLAGS
LDFLAGS_SAVE=$LDFLAGS
+LIBS_SAVE=$LIBS
CFLAGS="$CFLAGS $LIBGCRYPT_CFLAGS"
LDFLAGS="$LDFLAGS $LIBGCRYPT_LDFLAGS"
-LIBS_SAVE="$LIBS"
LIBS="-lgcrypt -lgpg-error $LIBS"