summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-05-12 21:38:38 +0200
committerChristian Grothoff <christian@grothoff.org>2019-05-12 21:48:16 +0200
commitbc29ca40803dc7ac01bc3918e51693ada5e74639 (patch)
tree7707cd6f1ac9053edbd2611e0412379727a6c95f /configure.ac
parent5740f5b63921c3a4012007f84da2670634b7d28a (diff)
downloadexchange-bc29ca40803dc7ac01bc3918e51693ada5e74639.tar.gz
exchange-bc29ca40803dc7ac01bc3918e51693ada5e74639.tar.bz2
exchange-bc29ca40803dc7ac01bc3918e51693ada5e74639.zip
replace if with AS_IF (#5709, wip)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8cdfa4cc..7006d377 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,9 +323,8 @@ AS_IF([test $jansson = 0],
# test for postgres
AX_LIB_POSTGRESQL([9.3])
-if test "$found_postgresql" = "yes"; then
- postgres=true
-fi
+AS_IF([test "x$found_postgresql" = "xyes"],[postgres=true])
+
else
@@ -444,9 +443,7 @@ fi])
# Currently these options are ELF specific - you can't use this with MacOSX
AC_ARG_ENABLE(linker-hardening,
AS_HELP_STRING(--enable-linker-hardening, enable linker security fixups),
-[if test x$enableval = xyes; then
- LDFLAGS="$LDFLAGS -z relro -z now"
-fi])
+ [AS_IF([test x$enableval = xyes],[LDFLAGS="$LDFLAGS -z relro -z now"])])
# logging