summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-03-04 00:56:05 +0100
committerChristian Grothoff <christian@grothoff.org>2018-03-04 00:56:05 +0100
commitae2f61947bcb0439413c97b52d47369b7ba0738a (patch)
tree683876b08c707f4856f2a55aa5f98bf583bd01ab /configure.ac
parenta360d9c6a0538f8d4806745f74cb0eae75e91b69 (diff)
downloadexchange-ae2f61947bcb0439413c97b52d47369b7ba0738a.tar.gz
exchange-ae2f61947bcb0439413c97b52d47369b7ba0738a.tar.bz2
exchange-ae2f61947bcb0439413c97b52d47369b7ba0738a.zip
fix #5293
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac98
1 files changed, 50 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index 1b904b59..2f4cdaa9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,56 @@ AS_IF([test $libgnunetjson != 1],
*** ]])])
+# libcurl-gnutls
+LIBCURL_CHECK_CONFIG(,7.34.0,[curl=true],[curl=false])
+if test "x$curl" = xtrue
+then
+ LDFLAGS="-L$with_libcurl/lib $LDFLAGS"
+ CPPFLAGS="-I$with_libcurl/include $CPPFLAGS"
+ AC_CHECK_HEADERS([curl/curl.h],
+ AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]),
+ [curl=false])
+ # need libcurl-gnutls.so, everything else is not acceptable
+ AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false])
+ # cURL must support CURLINFO_TLS_SESSION, version >= 7.34
+
+fi
+if test x$curl = xfalse
+then
+ AM_CONDITIONAL(HAVE_LIBCURL, false)
+if test "$gnurl" = 0
+then
+ AC_MSG_WARN([GNUnet requires libcurl-gnutls >= 7.34])
+fi
+else
+ AM_CONDITIONAL(HAVE_LIBCURL, true)
+ AC_DEFINE([HAVE_LIBCURL],[1],[Have CURL])
+fi
+
+
+# Check for curl/curl.h and gnurl/curl.h so we can use #ifdef
+# HAVE_CURL_CURL_H later (the above LIBCURL_CHECK_CONFIG accepted
+# *either* header set).
+AC_CHECK_HEADERS([curl/curl.h],,
+ curl=false
+ AC_CHECK_HEADERS([gnurl/curl.h],,
+ gnurl=false))
+
+
+# libgnurl
+if test "x$gnurl" = "x0"
+then
+ if test "x$curl" = "x0"
+ then
+ AC_MSG_NOTICE([NOTICE: libgnurl not found. http client support will not be compiled.])
+ AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
+ else
+ AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.])
+ fi
+fi
+
+
+
# Check for GNUnet's libgnunetcurl.
libgnunetcurl=0
AC_MSG_CHECKING([for libgnunetcurl])
@@ -325,54 +375,6 @@ else
AM_CONDITIONAL(HAVE_LIBGNURL, [false])
fi
-# libcurl-gnutls
-LIBCURL_CHECK_CONFIG(,7.34.0,[curl=true],[curl=false])
-if test "x$curl" = xtrue
-then
- LDFLAGS="-L$with_libcurl/lib $LDFLAGS"
- CPPFLAGS="-I$with_libcurl/include $CPPFLAGS"
- AC_CHECK_HEADERS([curl/curl.h],
- AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]),
- [curl=false])
- # need libcurl-gnutls.so, everything else is not acceptable
- AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false])
- # cURL must support CURLINFO_TLS_SESSION, version >= 7.34
-
-fi
-if test x$curl = xfalse
-then
- AM_CONDITIONAL(HAVE_LIBCURL, false)
-if test "$gnurl" = 0
-then
- AC_MSG_WARN([GNUnet requires libcurl-gnutls >= 7.34])
-fi
-else
- AM_CONDITIONAL(HAVE_LIBCURL, true)
- AC_DEFINE([HAVE_LIBCURL],[1],[Have CURL])
-fi
-
-
-# Check for curl/curl.h and gnurl/curl.h so we can use #ifdef
-# HAVE_CURL_CURL_H later (the above LIBCURL_CHECK_CONFIG accepted
-# *either* header set).
-AC_CHECK_HEADERS([curl/curl.h],,
- curl=false
- AC_CHECK_HEADERS([gnurl/curl.h],,
- gnurl=false))
-
-
-# libgnurl
-if test "x$gnurl" = "x0"
-then
- if test "x$curl" = "x0"
- then
- AC_MSG_NOTICE([NOTICE: libgnurl not found. http client support will not be compiled.])
- AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
- else
- AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.])
- fi
-fi
-
CFLAGS=$CFLAGS_SAVE
LDFLAGS=$LDFLAGS_SAVE
LIBS=$LIBS_SAVE