summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-03-20 23:51:28 +0100
committerChristian Grothoff <christian@grothoff.org>2015-03-20 23:51:28 +0100
commit7d9a40327587ed99fb20f4c4a5669069c7a51e48 (patch)
tree40ed8371340ef3d36269e0c9d23c4daae23fb039 /configure.ac
parent0414fb51a9f219c37afc06ad2b309711e360c485 (diff)
downloadexchange-7d9a40327587ed99fb20f4c4a5669069c7a51e48.tar.gz
exchange-7d9a40327587ed99fb20f4c4a5669069c7a51e48.tar.bz2
exchange-7d9a40327587ed99fb20f4c4a5669069c7a51e48.zip
first stab at establishing proper plugin API, main HTTP code compiles, other binaries FTBFS right now
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5835cb635..f69bcefd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,13 @@ AS_IF([test $libgnunetutil != 1],
*** ]])])
+TALER_LIB_LDFLAGS="-export-dynamic -no-undefined"
+TALER_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
+
+AC_SUBST(TALER_LIB_LDFLAGS)
+AC_SUBST(TALER_PLUGIN_LDFLAGS)
+
+
# check for libmicrohttpd
microhttpd=0
AC_MSG_CHECKING([for microhttpd])