summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-01-24 15:17:31 +0100
committerChristian Grothoff <christian@grothoff.org>2016-01-24 15:17:31 +0100
commit76b5350c30bb6d36ee548a7de554f388b5068e01 (patch)
tree888f3a669f08f115beab7d9caddf347e54f5c3b4 /configure.ac
parent8f071e2200f0421caf1969c71a16ed62b3356fb5 (diff)
downloadexchange-76b5350c30bb6d36ee548a7de554f388b5068e01.tar.gz
exchange-76b5350c30bb6d36ee548a7de554f388b5068e01.tar.bz2
exchange-76b5350c30bb6d36ee548a7de554f388b5068e01.zip
do not link everything against libcurl...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a64cbff7..ccb0c1f31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,6 +199,10 @@ TALER_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
AC_SUBST(TALER_LIB_LDFLAGS)
AC_SUBST(TALER_PLUGIN_LDFLAGS)
+CFLAGS_SAVE=$CFLAGS
+LDFLAGS_SAVE=$LDFLAGS
+LIBS_SAVE="$LIBS"
+
AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
@@ -249,6 +253,10 @@ then
fi
fi
+CFLAGS=$CFLAGS_SAVE
+LDFLAGS=$LDFLAGS_SAVE
+LIBS=$LIBS_SAVE
+
# should developer logic be compiled (not-for-production code)?
AC_MSG_CHECKING(whether to compile developer logic)