summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-05-12 21:39:25 +0200
committerChristian Grothoff <christian@grothoff.org>2019-05-12 21:48:16 +0200
commit652659a8d4fdb762f5833349506a837183a749ab (patch)
tree284eaf51633329959942d1496dd8bcbdd9aeb436 /configure.ac
parentbc29ca40803dc7ac01bc3918e51693ada5e74639 (diff)
downloadexchange-652659a8d4fdb762f5833349506a837183a749ab.tar.gz
exchange-652659a8d4fdb762f5833349506a837183a749ab.tar.bz2
exchange-652659a8d4fdb762f5833349506a837183a749ab.zip
replace if with AS_IF (#5709, wip)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7006d377..583c1b2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -431,12 +431,11 @@ AC_DEFINE_UNQUOTED([HAVE_DEVELOPER],[$enable_dev],[1 if developer logic is enabl
# -D_FORTIFY_SOURCE=2 -fstack-protector-all
AC_ARG_ENABLE(gcc-hardening,
AS_HELP_STRING(--enable-gcc-hardening, enable compiler security checks),
-[if test x$enableval = xyes; then
+[AS_IF([test x$enableval = xyes],[
CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all"
CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector"
CFLAGS="$CFLAGS --param ssp-buffer-size=1"
- LDFLAGS="$LDFLAGS -pie"
-fi])
+ LDFLAGS="$LDFLAGS -pie"])])
# Linker hardening options