summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-05-12 21:33:55 +0200
committerChristian Grothoff <christian@grothoff.org>2019-05-12 21:48:16 +0200
commit335f82d081506194b451f7131f2083b368203b7a (patch)
tree681df631c7b5fb7a70edab536bd36998dd750c39 /configure.ac
parent081280a88bfd833187dd8996e6482327c74dde8b (diff)
downloadexchange-335f82d081506194b451f7131f2083b368203b7a.tar.gz
exchange-335f82d081506194b451f7131f2083b368203b7a.tar.bz2
exchange-335f82d081506194b451f7131f2083b368203b7a.zip
replace if with AS_IF (#5709, wip)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3c1d9dd3..17a75602 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,11 +31,11 @@ AC_CONFIG_MACRO_DIR([m4])
LT_INIT
DX_INIT_DOXYGEN([taler-exchange],,,
-DX_PS_FEATURE(OFF),
-DX_PDF_FEATURE(OFF),
-DX_RTF_FEATURE(OFF),
-DX_CHI_FEATURE(OFF),
-DX_XML_FEATURE(OFF))
+ DX_PS_FEATURE(OFF),
+ DX_PDF_FEATURE(OFF),
+ DX_RTF_FEATURE(OFF),
+ DX_CHI_FEATURE(OFF),
+ DX_XML_FEATURE(OFF))
AC_MSG_CHECKING([whether to compile documentation ONLY])
AC_ARG_ENABLE([only-doc],
@@ -45,8 +45,9 @@ AC_ARG_ENABLE([only-doc],
AC_MSG_RESULT($doc_only)
AM_CONDITIONAL([DOC_ONLY], [test "x$doc_only" = "xyes"])
-if test "$doc_only" != yes
-then
+
+# Not indented, as most of the file falls under this one...
+AS_IF([test "x$doc_only" != xyes],[
# Checks for programs.
@@ -514,7 +515,8 @@ test "x$enable_doc" = "xno" || enable_doc=yes
AM_CONDITIONAL([ENABLE_DOC], [test "x$enable_doc" = "xyes"])
-else
+],[ # This is the big test "$doc_only" on top of the file!
+
# logic if doc_only is set, make sure conditionals are still defined
AM_CONDITIONAL([HAVE_EXPENSIVE_TESTS], [false])
@@ -529,7 +531,7 @@ AM_CONDITIONAL([ENABLE_DOC], [true])
AM_CONDITIONAL([HAVE_TWISTER], [false])
# end of 'doc_only'
-fi
+])
AC_CONFIG_FILES([Makefile
doc/Makefile