summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2015-12-13 17:03:32 +0100
committerFlorian Dold <florian.dold@gmail.com>2015-12-13 17:03:32 +0100
commit263fd77738a8b1749ecac0748328a72bdee4a5b5 (patch)
treeddf1304a8bd83492e0f98abbf574f50fa169cbd8 /configure.ac
parentc20f955ae43a57208b40d9a7978a7f089592ad60 (diff)
downloadexchange-263fd77738a8b1749ecac0748328a72bdee4a5b5.tar.gz
exchange-263fd77738a8b1749ecac0748328a72bdee4a5b5.tar.bz2
exchange-263fd77738a8b1749ecac0748328a72bdee4a5b5.zip
Only check for postgres if building full mint.
Otherwise the macro for postgres pulls unwanted system header files in and makes the build fail with emscripten.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 498053c35..6a64cbff7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,11 @@ AS_IF([test $jansson = 0],
*** ]])])
+# test for postgres
+AX_LIB_POSTGRESQL([9.3])
+if test "$found_postgresql" = "yes"; then
+ postgres=true
+fi
else
@@ -195,11 +200,6 @@ AC_SUBST(TALER_LIB_LDFLAGS)
AC_SUBST(TALER_PLUGIN_LDFLAGS)
-# test for postgres
-AX_LIB_POSTGRESQL([9.3])
-if test "$found_postgresql" = "yes"; then
- postgres=true
-fi
AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
# check for libgnurl