summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-01-05 11:16:27 +0100
committerFlorian Dold <florian@dold.me>2021-01-05 11:16:38 +0100
commit792d1f5f207dac31cb0b648e66970442933039c9 (patch)
treee73b13f0af03096efed87e766b32a616adb75415 /Makefile.am
parentaaeadf1598baf7b2193d03b17c73dcd8956dc9cb (diff)
downloadexchange-792d1f5f207dac31cb0b648e66970442933039c9.tar.gz
exchange-792d1f5f207dac31cb0b648e66970442933039c9.tar.bz2
exchange-792d1f5f207dac31cb0b648e66970442933039c9.zip
Revert "always and only build docs"
This reverts commit cdda3d34a3a3b8133a90d934707bf9065fd4471f.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d62e19a50..d2e8d8e05 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,19 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = . contrib src doc
+if DOC_ONLY
+if ENABLE_DOC
+ SUBDIRS = . contrib doc
+else
+ SUBDIRS = . contrib
+endif
+else
+if ENABLE_DOC
+ SUBDIRS = . contrib src doc
+else
+ SUBDIRS = . contrib src
+endif
+endif
BUILT_SOURCES = src/include/taler_error_codes.h