summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-06-04 10:22:11 +0200
committerChristian Grothoff <christian@grothoff.org>2017-06-04 11:11:36 +0200
commitc7c7ac60cf8b6dae5b9b8c0872dbe3d83020549d (patch)
tree1a70bc8be4842297182cd0b941f4bd5dbc462206 /Makefile.am
parent9f7e3bb2bd494860c31aa534942de85636cb91a8 (diff)
downloadexchange-c7c7ac60cf8b6dae5b9b8c0872dbe3d83020549d.tar.gz
exchange-c7c7ac60cf8b6dae5b9b8c0872dbe3d83020549d.tar.bz2
exchange-c7c7ac60cf8b6dae5b9b8c0872dbe3d83020549d.zip
cleaning up use of doxygen, fixing #5057
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4bbc20821..a73d4d863 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,19 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = src doc
+
+if DOC_ONLY
+ SUBDIRS = . doc
+else
+ SUBDIRS = . src doc
+endif
+
+@DX_RULES@
+
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
AUTHORS \
- contrib/coverage.sh
+ contrib/coverage.sh \
+ Doxyfile
app:
mkdir -p $(PACKAGE)-$(VERSION)-app