summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-03-17 16:14:28 +0100
committerChristian Grothoff <christian@grothoff.org>2016-03-17 16:14:28 +0100
commit7479f3a2e53655c6190bf5bcdb31736bf41a56c6 (patch)
treecf7615482e95457b95877a27f4961e1d29861851 /Makefile.am
parentaba92c5bfa3efa9a7cabf2fc85b1f14bea2d8307 (diff)
downloadexchange-7479f3a2e53655c6190bf5bcdb31736bf41a56c6.tar.gz
exchange-7479f3a2e53655c6190bf5bcdb31736bf41a56c6.tar.bz2
exchange-7479f3a2e53655c6190bf5bcdb31736bf41a56c6.zip
add APP target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cbf014371..a0ff82d54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,9 @@
AM_CPPFLAGS = -I$(top_srcdir)/src/include
SUBDIRS = src doc
ACLOCAL_AMFLAGS = -I m4
+
+app:
+ mkdir -p $(PACKAGE)-$(VERSION)-app
+ tar cf - configure.ac AUTHORS README doc/*.1 doc/*.5 doc/Makefile.am Makefile.am `find src/ -name "*.c" -o -name "*.h" -o -name Makefile.am` | (cd $(PACKAGE)-$(VERSION)-app ; tar xf -)
+ tar cf $(PACKAGE)-$(VERSION)-app.tgz $(PACKAGE)-$(VERSION)-app
+ rm -rf $(PACKAGE)-$(VERSION)-app