summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8852d84..c7440be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,16 @@ AC_MSG_RESULT([$VERSION])
AX_COMPARE_VERSION([$VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
+# On Debian systems, we may need to pass "--system" to pip3 to get
+# to the desired installation target directory
+pip3 install --help | grep '\-\-system' >> /dev/null
+if test $? -ne 0;
+then
+ DEBIAN_PIP3_SYSTEM=""
+else
+ DEBIAN_PIP3_SYSTEM="--system"
+fi
+AC_SUBST(DEBIAN_PIP3_SYSTEM)
#
# Check for tsc