summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac65
1 files changed, 65 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c1acc55
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,65 @@
+AC_INIT([talerdonations], [0.1.0], [taler-bug@gnunet.org])
+
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE
+AC_PROG_AWK
+AC_PROG_SED
+
+#
+# Check for Python
+#
+
+PC_INIT([3.4])
+pyheaders=0
+PC_PYTHON_CHECK_HEADERS([pyheaders=1])
+
+#
+# Check for pip3
+#
+
+AC_MSG_CHECKING([pip3])
+pip3 --version >/dev/null
+if test $? -ne 0;
+ then
+ AC_MSG_ERROR([Please install pip3>=6.0])
+fi
+
+VERSION=$(pip3 --version | $AWK '{ print $2 }')
+
+AC_MSG_RESULT([$VERSION])
+
+AX_COMPARE_VERSION([$VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
+
+
+#
+# Check for tsc
+#
+AC_CHECK_PROG([tsc],[tsc],[yes],[no])
+AM_CONDITIONAL([HAVE_TSC], [test "x$tsc" = xyes])
+
+#
+# Check for minifier
+#
+AC_MSG_CHECKING([Checking for jsmin])
+python3 -m jsmin &> /dev/null
+if test $? -ne 0;
+ then
+ AC_MSG_ERROR([Please install Python3 module 'jsmin'])
+fi
+
+#
+# Report
+#
+if test x$pyheaders != x1; then
+ AC_MSG_WARN([Python headers not installed, might be required to build uwsgi])
+fi
+
+
+#
+# Finish
+#
+
+AC_CONFIG_FILES([Makefile
+ talerdonations/donations/static/web-common/Makefile])
+
+AC_OUTPUT