summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-09-25 19:27:38 +0000
committerng0 <ng0@n0.is>2019-09-25 19:27:38 +0000
commit6a346edfe7fad92abbf6d7f6fc2e04602eff3d10 (patch)
tree0584b8949ae7e7b382914ea9155f31a959030b73 /configure.ac
parent3aeaaa760a4bc00d35b1faa0c7bde47e9a00b9b3 (diff)
parent38acb9f039fb01a7bc0aef8b93a277e919899ae9 (diff)
downloaddonations-6a346edfe7fad92abbf6d7f6fc2e04602eff3d10.tar.gz
donations-6a346edfe7fad92abbf6d7f6fc2e04602eff3d10.tar.bz2
donations-6a346edfe7fad92abbf6d7f6fc2e04602eff3d10.zip
Merge branch 'master' of git.taler.net:donations
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac76
1 files changed, 0 insertions, 76 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index c7440be..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,76 +0,0 @@
-AC_INIT([talerdonations], [0.1.0], [taler-bug@gnunet.org])
-
-AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE
-AC_PROG_AWK
-AC_PROG_SED
-
-#
-# Check for Python
-#
-
-PC_INIT([3.4])
-pyheaders=0
-PC_PYTHON_CHECK_HEADERS([pyheaders=1])
-PC_PYTHON_CHECK_VERSION()
-
-#
-# Check for pip3
-#
-
-AC_MSG_CHECKING([pip3])
-pip3 --version >/dev/null
-if test $? -ne 0;
- then
- AC_MSG_ERROR([Please install pip3>=6.0])
-fi
-
-VERSION=$(pip3 --version | $AWK '{ print $2 }')
-
-AC_MSG_RESULT([$VERSION])
-
-AX_COMPARE_VERSION([$VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
-
-# On Debian systems, we may need to pass "--system" to pip3 to get
-# to the desired installation target directory
-pip3 install --help | grep '\-\-system' >> /dev/null
-if test $? -ne 0;
-then
- DEBIAN_PIP3_SYSTEM=""
-else
- DEBIAN_PIP3_SYSTEM="--system"
-fi
-AC_SUBST(DEBIAN_PIP3_SYSTEM)
-
-#
-# Check for tsc
-#
-AC_CHECK_PROG([tsc],[tsc],[yes],[no])
-AM_CONDITIONAL([HAVE_TSC], [test "x$tsc" = xyes])
-
-#
-# Check for minifier
-#
-AC_MSG_CHECKING([Checking for jsmin])
-python3 -m jsmin &> /dev/null
-if test $? -ne 0;
- then
- AC_MSG_ERROR([Please install Python3 module 'jsmin'])
-fi
-
-#
-# Report
-#
-if test x$pyheaders != x1; then
- AC_MSG_WARN([Python headers not installed, might be required to build uwsgi])
-fi
-
-
-#
-# Finish
-#
-
-AC_CONFIG_FILES([Makefile
- talerdonations/donations/static/web-common/Makefile])
-
-AC_OUTPUT