diff options
Diffstat (limited to 'src/cli/Makefile.am')
-rw-r--r-- | src/cli/Makefile.am | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/src/cli/Makefile.am b/src/cli/Makefile.am new file mode 100644 index 0000000..6b8bf23 --- /dev/null +++ b/src/cli/Makefile.am | |||
@@ -0,0 +1,56 @@ | |||
1 | # This Makefile.am is in the public domain | ||
2 | AM_CPPFLAGS = -I$(top_srcdir)/src/include | ||
3 | |||
4 | bin_PROGRAMS = \ | ||
5 | anastasis-reducer | ||
6 | |||
7 | if USE_COVERAGE | ||
8 | AM_CFLAGS = --coverage -O0 | ||
9 | XLIB = -lgcov | ||
10 | endif | ||
11 | |||
12 | check_SCRIPTS = \ | ||
13 | test_anastasis_reducer_initialize_state.sh \ | ||
14 | test_anastasis_reducer_select_continent.sh \ | ||
15 | test_anastasis_reducer_select_country.sh \ | ||
16 | test_anastasis_reducer_backup_enter_user_attributes.sh \ | ||
17 | test_anastasis_reducer_add_authentication.sh \ | ||
18 | test_anastasis_reducer_done_authentication.sh \ | ||
19 | test_anastasis_reducer_done_policy_review.sh \ | ||
20 | test_anastasis_reducer_enter_secret.sh \ | ||
21 | test_anastasis_reducer_recovery_enter_user_attributes.sh | ||
22 | |||
23 | |||
24 | AM_TESTS_ENVIRONMENT=export ANASTASIS_PREFIX=$${ANASTASIS_PREFIX:-@libdir@};export PATH=$${ANASTASIS_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; | ||
25 | |||
26 | TESTS = \ | ||
27 | $(check_SCRIPTS) | ||
28 | |||
29 | EXTRA_DIST = \ | ||
30 | $(check_SCRIPTS) \ | ||
31 | test_reducer.conf \ | ||
32 | test_anastasis_reducer_1.conf \ | ||
33 | test_anastasis_reducer_2.conf \ | ||
34 | test_anastasis_reducer_3.conf \ | ||
35 | test_anastasis_reducer_4.conf \ | ||
36 | resources/00-backup.json \ | ||
37 | resources/01-backup.json \ | ||
38 | resources/02-backup.json \ | ||
39 | resources/03-backup.json \ | ||
40 | resources/04-backup.json \ | ||
41 | resources/00-recovery.json \ | ||
42 | resources/01-recovery.json \ | ||
43 | resources/02-recovery.json | ||
44 | |||
45 | anastasis_reducer_SOURCES = \ | ||
46 | anastasis-cli-redux.c | ||
47 | anastasis_reducer_LDADD = \ | ||
48 | $(top_builddir)/src/util/libanastasisutil.la \ | ||
49 | $(top_builddir)/src/reducer/libanastasisredux.la \ | ||
50 | -ltalerjson \ | ||
51 | -ltalerutil \ | ||
52 | -lgnunetjson \ | ||
53 | -lgnunetcurl \ | ||
54 | -lgnunetutil \ | ||
55 | -ljansson \ | ||
56 | $(XLIB) | ||