summaryrefslogtreecommitdiff
path: root/doc/doxygen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/doxygen/Makefile.am')
-rw-r--r--doc/doxygen/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644
index 0000000..344d45c
--- /dev/null
+++ b/doc/doxygen/Makefile.am
@@ -0,0 +1,18 @@
+# This Makefile.am is in the public domain
+all:
+ @echo -e \
+"Generate documentation:\n" \
+"\tmake full - full documentation with dependency graphs (slow)\n" \
+"\tmake fast - fast mode without dependency graphs"
+
+full: anastasis.doxy
+ doxygen $<
+
+fast: anastasis.doxy
+ sed 's/\(HAVE_DOT.*=\).*/\1 NO/' $< | doxygen -
+
+clean:
+ rm -rf html
+
+EXTRA_DIST = \
+ anastasis.doxy