aboutsummaryrefslogtreecommitdiff
path: root/doc/doxygen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/doxygen/Makefile.am')
-rw-r--r--doc/doxygen/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644
index 0000000..344d45c
--- /dev/null
+++ b/doc/doxygen/Makefile.am
@@ -0,0 +1,18 @@
1# This Makefile.am is in the public domain
2all:
3 @echo -e \
4"Generate documentation:\n" \
5"\tmake full - full documentation with dependency graphs (slow)\n" \
6"\tmake fast - fast mode without dependency graphs"
7
8full: anastasis.doxy
9 doxygen $<
10
11fast: anastasis.doxy
12 sed 's/\(HAVE_DOT.*=\).*/\1 NO/' $< | doxygen -
13
14clean:
15 rm -rf html
16
17EXTRA_DIST = \
18 anastasis.doxy