diff options
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r-- | contrib/Makefile.am | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am index c0ab873..a360ab5 100644 --- a/contrib/Makefile.am +++ b/contrib/Makefile.am | |||
@@ -3,10 +3,44 @@ | |||
3 | 3 | ||
4 | SUBDIRS = . | 4 | SUBDIRS = . |
5 | 5 | ||
6 | # English (en) | ||
7 | tosendir=$(datadir)/anastasis/tos/en | ||
8 | |||
9 | # English (en) | ||
10 | ppendir=$(datadir)/anastasis/pp/en | ||
11 | |||
12 | tosen_DATA = \ | ||
13 | tos/en/0.txt \ | ||
14 | tos/en/0.pdf \ | ||
15 | tos/en/0.epub \ | ||
16 | tos/en/0.xml \ | ||
17 | tos/en/0.html | ||
18 | |||
19 | ppen_DATA = \ | ||
20 | pp/en/0.txt \ | ||
21 | pp/en/0.pdf \ | ||
22 | pp/en/0.epub \ | ||
23 | pp/en/0.xml \ | ||
24 | pp/en/0.html | ||
25 | |||
26 | |||
27 | |||
6 | pkgdatadir= $(prefix)/share/anastasis/ | 28 | pkgdatadir= $(prefix)/share/anastasis/ |
7 | 29 | ||
8 | EXTRA_DIST = \ | 30 | EXTRA_DIST = \ |
9 | $(pkgdata_DATA) \ | 31 | $(pkgdata_DATA) \ |
32 | $(tosen_DATA) \ | ||
33 | $(ppen_DATA) \ | ||
34 | tos/Makefile \ | ||
35 | tos/README \ | ||
36 | tos/tos.rst \ | ||
37 | tos/conf.py \ | ||
38 | tos/locale/de/LC_MESSAGES/tos.po \ | ||
39 | pp/Makefile \ | ||
40 | pp/README \ | ||
41 | pp/pp.rst \ | ||
42 | pp/conf.py \ | ||
43 | pp/locale/de/LC_MESSAGES/pp.po \ | ||
10 | pogen.sh \ | 44 | pogen.sh \ |
11 | uncrustify.cfg \ | 45 | uncrustify.cfg \ |
12 | uncrustify_precommit \ | 46 | uncrustify_precommit \ |
@@ -30,3 +64,19 @@ pkgdata_DATA = \ | |||
30 | redux.xy.json \ | 64 | redux.xy.json \ |
31 | redux.countries.json \ | 65 | redux.countries.json \ |
32 | provider-list.json | 66 | provider-list.json |
67 | |||
68 | # Change the set of supported languages here. You should | ||
69 | # also update tos'XX'data and EXTRA_DIST accordingly. | ||
70 | TOS_LANGUAGES="en de" | ||
71 | PP_LANGUAGES="en de" | ||
72 | |||
73 | # Change the terms-of-service version (Etag) to generate here! | ||
74 | # This value should be incremented whenever there is a substantive | ||
75 | # change in the original text (but not for the translations). | ||
76 | TOS_VERSION=0 | ||
77 | PP_VERSION=0 | ||
78 | |||
79 | update-tos: | ||
80 | VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES) | ||
81 | update-pp: | ||
82 | VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES) | ||