summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am69
1 files changed, 22 insertions, 47 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index a360ab5..47c5e8e 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -3,50 +3,39 @@
SUBDIRS = .
-# English (en)
-tosendir=$(datadir)/anastasis/tos/en
+bin_SCRIPTS = \
+ anastasis-dbconfig
-# English (en)
-ppendir=$(datadir)/anastasis/pp/en
+termsdir=$(datadir)/anastasis/terms/
+terms_DATA = \
+ anastasis-tos-v0.rst \
+ anastasis-pp-v0.rst
-tosen_DATA = \
- tos/en/0.txt \
- tos/en/0.pdf \
- tos/en/0.epub \
- tos/en/0.xml \
- tos/en/0.html
-
-ppen_DATA = \
- pp/en/0.txt \
- pp/en/0.pdf \
- pp/en/0.epub \
- pp/en/0.xml \
- pp/en/0.html
+install-exec-local:
+ find locale/ -name "*.po"
+ mkdir -p $(DESTDIR)$(datadir)
+ cp --parents -r $$(find locale/ -name "*.po") $(DESTDIR)$(datadir)
+extracted.h: *.json
+ ./extract.sh
+noinst_SCRIPTS = extracted.h
pkgdatadir= $(prefix)/share/anastasis/
EXTRA_DIST = \
+ locale/de/LC_MESSAGES/anastasis-tos-v0.po \
+ $(bin_SCRIPTS) \
$(pkgdata_DATA) \
- $(tosen_DATA) \
- $(ppen_DATA) \
- tos/Makefile \
- tos/README \
- tos/tos.rst \
- tos/conf.py \
- tos/locale/de/LC_MESSAGES/tos.po \
- pp/Makefile \
- pp/README \
- pp/pp.rst \
- pp/conf.py \
- pp/locale/de/LC_MESSAGES/pp.po \
+ $(terms_DATA) \
pogen.sh \
uncrustify.cfg \
uncrustify_precommit \
gana.sh \
gana-update.sh \
- microhttpd.tag
+ microhttpd.tag \
+ extract.sh \
+ extracted.h
pkgdata_DATA = \
redux.al.json \
@@ -55,28 +44,14 @@ pkgdata_DATA = \
redux.cz.json \
redux.de.json \
redux.dk.json \
+ redux.es.json \
+ redux.fr.json \
redux.in.json \
redux.it.json \
redux.jp.json \
+ redux.nl.json \
redux.sk.json \
redux.us.json \
redux.xx.json \
- redux.xy.json \
redux.countries.json \
provider-list.json
-
-# Change the set of supported languages here. You should
-# also update tos'XX'data and EXTRA_DIST accordingly.
-TOS_LANGUAGES="en de"
-PP_LANGUAGES="en de"
-
-# Change the terms-of-service version (Etag) to generate here!
-# This value should be incremented whenever there is a substantive
-# change in the original text (but not for the translations).
-TOS_VERSION=0
-PP_VERSION=0
-
-update-tos:
- VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
-update-pp:
- VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)