summaryrefslogtreecommitdiff
path: root/src/restclient/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-07-30 10:38:27 +0200
committerChristian Grothoff <christian@grothoff.org>2021-07-30 10:38:27 +0200
commit7e669bcf6b6336ec429da949bcb4aa456971dba2 (patch)
treed19912f950d1cac1c38b857b7d5bdaba2289544e /src/restclient/Makefile.am
downloadanastasis-7e669bcf6b6336ec429da949bcb4aa456971dba2.tar.gz
anastasis-7e669bcf6b6336ec429da949bcb4aa456971dba2.tar.bz2
anastasis-7e669bcf6b6336ec429da949bcb4aa456971dba2.zip
folding history in preparation of GNU Anastasis v0.0.0 release
Diffstat (limited to 'src/restclient/Makefile.am')
-rw-r--r--src/restclient/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/restclient/Makefile.am b/src/restclient/Makefile.am
new file mode 100644
index 0000000..075d3a7
--- /dev/null
+++ b/src/restclient/Makefile.am
@@ -0,0 +1,42 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/backend -I$(top_srcdir)/src/lib
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+.NOTPARALLEL:
+
+lib_LTLIBRARIES = \
+ libanastasisrest.la
+
+libanastasisrest_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined
+libanastasisrest_la_SOURCES = \
+ anastasis_api_config.c \
+ anastasis_api_policy_store.c \
+ anastasis_api_truth_store.c \
+ anastasis_api_policy_lookup.c \
+ anastasis_api_keyshare_lookup.c \
+ anastasis_api_curl_defaults.c anastasis_api_curl_defaults.h
+libanastasisrest_la_LIBADD = \
+ -lgnunetcurl \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ -ltalerjson \
+ -ltalerutil \
+ -ltalermerchant \
+ -ltalerjson \
+ $(XLIB)
+
+if HAVE_LIBCURL
+libanastasisrest_la_LIBADD += -lcurl
+else
+if HAVE_LIBGNURL
+libanastasisrest_la_LIBADD += -lgnurl
+endif
+endif
+