summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-09-07 21:46:49 +0200
committerChristian Grothoff <christian@grothoff.org>2021-09-07 21:46:49 +0200
commit2cd354167edcbd9542160f3ec94493a8ecf09e8c (patch)
tree75f6598edb1209a98e5429c4fd265ad6f431b6e7 /contrib/Makefile.am
parent19dcdc7fe256e7dc68c64027315faff480c03da8 (diff)
downloadanastasis-2cd354167edcbd9542160f3ec94493a8ecf09e8c.tar.gz
anastasis-2cd354167edcbd9542160f3ec94493a8ecf09e8c.tar.bz2
anastasis-2cd354167edcbd9542160f3ec94493a8ecf09e8c.zip
deploy pp/terms for Anastasis
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index c0ab873..a360ab5 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -3,10 +3,44 @@
SUBDIRS = .
+# English (en)
+tosendir=$(datadir)/anastasis/tos/en
+
+# English (en)
+ppendir=$(datadir)/anastasis/pp/en
+
+tosen_DATA = \
+ tos/en/0.txt \
+ tos/en/0.pdf \
+ tos/en/0.epub \
+ tos/en/0.xml \
+ tos/en/0.html
+
+ppen_DATA = \
+ pp/en/0.txt \
+ pp/en/0.pdf \
+ pp/en/0.epub \
+ pp/en/0.xml \
+ pp/en/0.html
+
+
+
pkgdatadir= $(prefix)/share/anastasis/
EXTRA_DIST = \
$(pkgdata_DATA) \
+ $(tosen_DATA) \
+ $(ppen_DATA) \
+ tos/Makefile \
+ tos/README \
+ tos/tos.rst \
+ tos/conf.py \
+ tos/locale/de/LC_MESSAGES/tos.po \
+ pp/Makefile \
+ pp/README \
+ pp/pp.rst \
+ pp/conf.py \
+ pp/locale/de/LC_MESSAGES/pp.po \
pogen.sh \
uncrustify.cfg \
uncrustify_precommit \
@@ -30,3 +64,19 @@ pkgdata_DATA = \
redux.xy.json \
redux.countries.json \
provider-list.json
+
+# Change the set of supported languages here. You should
+# also update tos'XX'data and EXTRA_DIST accordingly.
+TOS_LANGUAGES="en de"
+PP_LANGUAGES="en de"
+
+# Change the terms-of-service version (Etag) to generate here!
+# This value should be incremented whenever there is a substantive
+# change in the original text (but not for the translations).
+TOS_VERSION=0
+PP_VERSION=0
+
+update-tos:
+ VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
+update-pp:
+ VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)