summaryrefslogtreecommitdiff
path: root/library/src/main/cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'library/src/main/cpp/CMakeLists.txt')
-rw-r--r--library/src/main/cpp/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/library/src/main/cpp/CMakeLists.txt b/library/src/main/cpp/CMakeLists.txt
new file mode 100644
index 00000000..b2983d0b
--- /dev/null
+++ b/library/src/main/cpp/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.4.1)
+
+add_library(akono-jni SHARED
+ akono-jni.c)
+
+add_library(v8 STATIC IMPORTED)
+set_target_properties(v8 PROPERTIES IMPORTED_LOCATION
+ ${distribution_DIR}/gperf/lib/${ANDROID_ABI}/libgperf.so)
+
+
+# Include libraries needed for hello-jni lib
+target_link_libraries(akono-jni
+ android
+ log)
+